Mailing List Message #259
From: Valerio Luccio <>
Subject: Missing class issue
Date: Thu, 16 Sep 2021 19:15:22 -0400
To: Morris, Mark <>

Hello all,

I have an application that has been running for a very long time on an old OS X server. I've finally had a chance to set up a new Linux (Centos) server and install the application there. Everything works, except one thing: one option is to generate an Excel file. I use the Wonder ExcelGenerator poi jar. When you try that option you get a java.lang.NoClassDefFoundError for any of the classes in the poi jar file.

The library is installed in /opt/Wonder/Frameworks/Excel/ExcelGenerator/Libraries/poi-3.17.jar

I've tried including it specifically in the CLASSPATH in the womonitor and wotaskd startup and I've also tried to specify it in the UNIX/UNIXClassPath.txt and in the configuration in the Monitor, but to no avail.

I'm at my wits' end.

Thanks in advance.

Valerio Luccio     (212) 998-8736
Center for Brain Imaging     4 Washington Place, Room 158
New York University     New York, NY 10003

"In an open world, who needs windows or gates ?"
Subscribe (FEED) Subscribe (DIGEST) Subscribe (INDEX) Unsubscribe Mail to Listmaster