Mailing List Message #98
From: Jeffrey Schmitz <>
Subject: Re: [WO-DEV] address isn't valid error
Date: Wed, 10 Mar 2021 17:49:31 -0600
To: WebObjects & WOnder Development <>
The error had to do with a bad check I was doing for if the app was running in the dev environment, in which case it doesn't make any of the pages encrypted.  It was based on a specific home network, but I just added a second one and my laptop sometimes connects to it.

So.. it was trying to generate an encrypted page when running in direct connect mode.  I'm not sure why it would lead to the error I was seeing which didn't indicate that the URL being processed by the browser was a secure one (no https and no secure port), but I can certainly see where it would lead to an error.

btw, here is the error Firefox was giving..

The site at http://localhost:49292/cgi-bin/WebObjects/netBrackets.woa/wa/poolLogin?wosid=vb8wmpwIAAHfPJVx35pJCg has experienced a network protocol violation that cannot be repaired.


On Mar 10, 2021, at 11:29 AM, Aaron Rosenzweig <> wrote:

Jeff, probably spoked Safari’s content blocker or a safari extension of some sort causing grief. 

I’d first try a different browser like Firefox or Chrome and see if it is “ok” - if it is, then you know it’s a Safari issue. 

If you can narrow it to Safari then try disabling extensions (if you have them) and the content blocker too. If it starts working then you need to think harder about what is different. 

I don’t know, maybe there is a JS error… maybe you think the two URLs load the same but did you verify the HTML source that they generate through another browser? 

Yeah, it’s a head scratcher for sure but those are my first thoughts. 

On Mar 9, 2021, at 7:05 PM, Jeffrey Schmitz <> wrote:

Hello List,
   I'm using direct connect for local development on my laptop, and all the sudden when I bring up my app, if I click to go to any page I get (for example):

  "Safari can't open the page localhost:65449/cgi-bin/WebObjects/netBrackets.woa/wa/poolLogin because the page's address isn't valid"

Note that the main page comes up fine.

but the below page does not because the "address isn't valid" according to Safari:

I set my debugger to block in the performActionNamed function in the DirectAction class, and that seemlngly returns a good WOActionResults object.

Any ideas what might be causing this?  I've tried using Apache to debug but I always get an Application can't be found error when I run my app to debug, but that's another story.


Subscribe (FEED) Subscribe (DIGEST) Subscribe (INDEX) Unsubscribe Mail to Listmaster